Script DynDNS en MikroTik RouterBoard

Script DynDNS en MikroTik

El Script DynDNS en MikroTik nos proporciona una dirección de Internet a lo que le llamamos dominio de forma gratuita o paga, como ejemplo xxx.dyndns.org, pero te preguntaras ¿esto que tiene de novedoso?. Simplemente que DynDNS hace que tu RB tenga un nombre en internet y tu RB Mikrotik podría funcionar como hosting, servidor de FTP, entre otros.  Eso quiere decir que te puedes olvidar de publicidad por todos lados, direcciones largas o que tengas que pagar hosting aunque eso es algo relativo.

Una IP Dinámica es la que cambia cada vez que se conecta a Internet o que el servidor del servicio hace un reset al mismo, es el que muchos proveedores ISP hoy en día utilizan.

Para crear una cuenta en DynDNS entramos en nuestro navegador de preferencia  y nos dirigimos a la siguiente URL http://www.dyndns.com.

Luego de creada la cuenta entonces procedemos con la configuración según se muestra en el siguiente vídeo.


Script DynDNS

**** Cambia el nombre de usuario, clave y nombre de la tu interfaz WAN unicamente ****
:global ddnsuser "Usuario DynDns"
:global ddnspass "Pass Dyndns"
:global theinterface "Nombre de La Interface WAN de ISP"
:global ddnshost DOMINIO que tengas
:global ipddns [:resolve $ddnshost];
:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
:if ([ :typeof $ipfresh ] = nil ) do={
:log info ("DynDNS: No ip address on $theinterface .")
} else={
:for i from=( [:len $ipfresh] - 1) to=0 do={
:if ( [:pick $ipfresh $i] = "/") do={
:set ipfresh [:pick $ipfresh 0 $i];
}
}

:if ($ipddns != $ipfresh) do={
:log info ("DynDNS: IP-DynDNS = $ipddns")
:log info ("DynDNS: IP-Fresh = $ipfresh")
:log info "DynDNS: Update IP needed, Sending UPDATE...!"
:global str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser 
password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
:delay 1
:global str [/file find name="DynDNS.$ddnshost"];
/file remove $str
:global ipddns $ipfresh
:log info "DynDNS: IP updated to $ipfresh!"
} else={
:log info "DynDNS: dont need changes";
}
}

NOTA:  ACUERDATE DEL SCHEDULER

/system scheduler
add interval=1m name=DynDns on-event=DynDns policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=startup

Si te quedo alguna duda no lo pienses mas y visita Nuestro Foro, suscribete y podrás dejarnos tus preguntas donde con gusto estaremos respondiendo todas tus dudas.

Si quieres seguir aprendiendo sobre Routers lee nuestros artículos y conviértete en un experto aquí.



	
Acerca de admin 18 Articles
Especialista en redes de Internet, posicionamiento SEO y tecnología de Seguridad Integral. Brindo para ti mis conocimientos permitiendo el aumento de la información mediante el servicio de Internet a nivel mundial.

Be the first to comment

Leave a Reply

Tu dirección de correo no será publicada.


*


Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.