Configurar No-Ip en Mikrotik

Configurar No-Ip en MikroTik

Antes de Configurar No-Ip en MikroTik veamos los siguiente. El DDNS (Dynamic Domain Name System – Sistema del Nombre de Dominio Dinámico) es útil para propio sitio web, el servidor FTP u otro servicio detrás del router.

Este artículo ilustra cómo asignar un hotspot fijo / nombre de dominio a una dirección IP de Internet dinámico. Para configurar el DDNS No-IP con los routers MikroTik. para actualizar tu IP con el nombre de dominio creado a través de un sencillo Script.

El servicio de DNS dinámica de No-IP permite identificar tu PC con un nombre de dominio fácil de recordar, como TuNombre.no-ip.com en lugar de con un número extraño del tipo 215.151.218.150 y poder montar un servidor sin complicaciones independientemente de si tenemos o no una IP estática.

Lo primero que debemos hacer para configurar No-Ip en MikroTik es registrarnos en No-Ip.com, en la parte derecha tenemos la opción de “Sign Up”.

Ahora tienes que rellenar los datos que solicitan como el correo electrónico, usuario, contraseña y también el nombre de dominio que queramos. El nombre de dominio puedes añadirlo más tarde sin ningún problema, así que no os adelanta primero tu suscripción.

A continuación, hacemos clic en “Dynamic DNS/ Hostnames” tendremos un resumen de los nombres de dominio de nuestra cuenta. Si pinchamos en “Add Hostname” podremos crear un nuevo nombre de dominio en No-IP.

Luego de tener el nombre de dominio proseguimos con los pasos del siguiente Video para configurar No-Ip en MikroTik.

A Continuación te dejamos el Script para que lo hagas de manera Sencilla (Usuarios Medios-Avanzados).

Script No-IP para Mikrotik

# Actualización automatica de DNS con servicio de No-IP

#--------------- Cambia los siguientes valores para las variables ------------------


# Información de tu cuenta en No-IP
:local noipuser "Nombre de Usuario"
:local noippass "Clave"
# Nombre de Dominio Creado en No-IP
:local noiphost "El nombre que hayas creado Ejemplo: xxxprueba.no-ip.net"
# Cambia el nombre de tu interface de ISP o WAN y copiala como la tienes en tu # RB Mikrotik
:local inetinterface "Nombre de INTERFACE"

#--------------------------------YA No cambies ningún archivo-------------------------

:global previousIP [:resolve $noiphost];

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
   :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
   :for i from=( [:len $currentIP] - 1) to=0 do={
       :if ( [:pick $currentIP $i] = "/") do={ 
           :set currentIP [:pick $currentIP 0 $i]
       } 
   }

   :if ($currentIP != $previousIP) do={
       :log info "No-IP: La actual IP $currentIP no es igual a la anterior, necesita actualizar!"
       :set previousIP $currentIP

# The update URL. Note the "3F" is hex for question mark (?). Required since ? is a special character in commands.
       :local url "http://dynupdate.no-ip.com/nic/update3Fmyip=$currentIP"
       :local noiphostarray
       :set noiphostarray [:toarray $noiphost]
       :foreach host in=$noiphostarray do={
           :log info "No-IP: Se envio actualizacion para el siguiente Host $host"
           /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
           :log info "No-IP: El siguiente Host $host fue actualizado en No-IP con la siguiente direccion IP $currentIP"
       }
   }  else={
       :log info "No-IP: La anterior IP $previousIP es igual que la actual, no es necesario actualizar"
   }
} else={
   :log info "No-IP: No fue necesario actualizar la siguiente Interface: $inetinterface esta aun no ha cambiado."
}

Si te quedo alguna duda no lo pienses mas y visita Nuestro Foro, suscribete y podrás dejarnos tus preguntas donde con gusto estaremos respondiendo todas tus dudas.

Si quieres seguir aprendiendo sobre Routers lee nuestros artículos y conviértete en un experto aquí.

 

 

Be the first to comment

Leave a Reply

Tu dirección de correo no será publicada.


*


Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.